Inbound email traffic delayed for bossdesk.io addresses

Major incident Web
2024-06-17 18:34 · 8 hours, 27 minutes

Updates

Times are shown in Africa/Abidjan timezone
Resolved

The issue has been resolved on the Postmark side

June 18, 2024 · 03:00
Issue

the service that processes our inbound emails for the @bossdesk.io domain is currently experiencing processing delays. This does not affect customers utilizing their own internal email postboxes.

details here: https://status.postmarkapp.com/

June 17, 2024 · 18:34

← Back