BOSSDesk Degraded Performance
Major incident
Web
API
SiteAgent Services
2026-02-20 08:18 EST
· 44 minutes
Updates
Resolved
February 20, 2026 · 09:01 EST
An issue occurred within one of our pieces of back-end infrastructure. Once the location of the issue was identified, the service was restored.
Investigating
February 20, 2026 · 08:45 EST
Mitigation measures have been implemented, engineers are currently monitoring.
Issue
February 20, 2026 · 08:18 EST
BOSSDesk is experiencing elevated timeout errors. Engineers are investigating.
← Back