Issue with Service provider causing delays on incoming emails

Minor incident Web API
2022-07-28 13:22 EST · 1 hour, 14 minutes

Updates

Resolved

Emails appear to be processing normally

July 28, 2022 · 14:37 EST
Issue

The service we use to process inbound emails if you are not using your own exchange server is currently experiencing an outage. there may be delays on inbound emails. further details here:

https://status.postmarkapp.com/

July 28, 2022 · 13:25 EST

← Back